Willkommen! Melden Sie sich an oder registrieren Sie sich.

Um schreiben oder kommentieren zu können, benötigen Sie ein Benutzerkonto.

Anmelden - oder - Benutzerkonto erstellen

Nach Feed Wechsel werden Updates nicht durchgeführt

  • Hallo zusammen,


    ich hatte schon lange nichts mehr gemacht an meiner DM820, doch nun wollte ich wieder mal ein Update machen und dabei habe ich gelesen, das sich die Feeds geändert haben.

    Also habe ich die neuen Feeds eingetragen:


    deb [trusted=yes] http://feed.dreamboxtools.de/oe_2.5/deb/dm820/all ./

    deb [trusted=yes] http://feed.dreamboxtools.de/oe_2.5/deb/dm820/mips32el ./

    deb [trusted=yes] http://feed.dreamboxtools.de/oe_2.5/deb/dm820/dm820 ./

    deb [trusted=yes] http://feed.dreamboxtools.de/oe_2.5/deb/merlin4-thirdparty ./

    deb [trusted=yes] http://feed.dreamboxtools.de/oe_2.5/deb/merlin4-plugins ./

    deb [trusted=yes] http://feed.dreamboxtools.de/oe_2.5/deb/merlin4-skins ./


    Danach hat die Box auch ich 303 neue updates gefunden, aber es werden keine installiert, da der Prozess mit Fehler beendet wird:



    Reading package lists...
    Building dependency tree...
    Reading state information...
    The following packages were automatically installed and are no longer required:
    enigma2-plugin-skincomponents-eventnameextra libavcodec54 libavformat54
    libavutil52 libqtsvge4 libqtwebkite4 libtiff5
    qt4-embedded-plugin-imageformat-gif qt4-embedded-plugin-imageformat-ico
    qt4-embedded-plugin-imageformat-svg qt4-embedded-plugin-imageformat-tiff
    Use 'apt-get autoremove' to remove them.
    The following packages will be REMOVED:
    bluez4 libjpeg8 ofono qt4-embedded-plugin-imageformat-jpeg
    The following NEW packages will be installed:
    alsa-conf arp-scan bash bash-completion bluez5 cdfs connman-wait-online
    debianutils debianutils-run-parts dreambox-bootlogo dreamliveserver enca

    ....

    (weg gelassen damit der post nicht so groß wird)

    ....

    303 upgraded, 206 newly installed, 4 to remove and 0 not upgraded.
    Need to get 0 B/88.3 MB of archives.
    After this operation, 0 B of additional disk space will be used.
    dpkg-deb: error: archive '/var/cache/apt/archives/libc6_2.23-r0.3_mipsel.deb' has premature member 'control.tar.xz' before 'control.tar.gz', giving up
    dpkg: error processing archive /var/cache/apt/archives/libc6_2.23-r0.3_mipsel.deb (--unpack):
    subprocess dpkg-deb --control returned error exit status 2
    Errors were encountered while processing:
    /var/cache/apt/archives/libc6_2.23-r0.3_mipsel.deb
    E: Sub-process /usr/bin/dpkg returned an error code (1)


    Ich habe auch mal den Ordner /var/cache/apt/archives gelehrt und dann nochmal gestartet, aber ohne Erfolg.

    Ich habe auch schon versucht das libc6_2.23-r0.3_mipsel.deb aus der liste zu löschen, um zu sehen, ob es daran liegt, aber es wird dann immer wieder neu geladen.


    Irgendwie komme ich hier nicht weiter.

    Kann mir da einer helfen?

  • Versuch mal nur dpkg zu aktualisieren

  • Das habe ich auch schon versucht, aber irgendwie bekomme ich das nicht hin.

    wenn ich im WebAdmin nach dpkg suche und dann dort auf UPDATE gehe, dann kommt der selbe Fehler:


    Reading package lists...
    Building dependency tree...
    Reading state information...
    The following extra packages will be installed:
    libc6 liblzma5
    Recommended packages:
    start-stop-daemon
    The following packages will be upgraded:
    dpkg libc6 liblzma5
    3 upgraded, 0 newly installed, 0 to remove and 300 not upgraded.
    Need to get 0 B/1272 kB of archives.
    After this operation, 0 B of additional disk space will be used.
    dpkg-deb: error: archive '/var/cache/apt/archives/libc6_2.23-r0.3_mipsel.deb' has premature member 'control.tar.xz' before 'control.tar.gz', giving up
    dpkg: error processing archive /var/cache/apt/archives/libc6_2.23-r0.3_mipsel.deb (--unpack):
    subprocess dpkg-deb --control returned error exit status 2
    Errors were encountered while processing:
    /var/cache/apt/archives/libc6_2.23-r0.3_mipsel.deb
    E: Sub-process /usr/bin/dpkg returned an error code (1)


    irgendwie verstehe ich es nicht ganz.

  • Hat denn niemand eine Idee, wie ich hier weiter kommen kann?


    die Box läuft, es lassen sich nur die Updates nicht installieren.

    Leider brauche ich die Updates, da ich gerade was am Video.db versuchen wollte.

    Aber dazu sollte die Box schon auf stand sein.

    Wie bekomme ich zb nur einzelne Updates installiert?


    so wie es scheint, liegt es am Installationsprozess selbst.

    Aber zu mehr reichen meine Kenntnisse leider nicht aus was da oben an Fehlern stehen.


    Eventuell kann mir das einer genauer erklären was da schief läuft?

  • Wüssten wir, was das Problem bei dir verursacht, hätten wir es dir wohl gesagt, oder?


    Wenn du das Update so unbedingt brauchst, dann bist du schneller, wenn du die Senderlisten sicherst und dann das aktuellste Image flashed.

  • Wie bekomme ich zb nur einzelne Updates installiert?

    Per Kommandozeile:


    # apt-get install <paketname>


    Und so würde ich bei einem APT/DPKG basierten System auch immer erst apt, dpkg und perl manuell updaten und danach erst mit dist-upgrade die ganze Distribution hochziehen.

  • oder mach ein backup übern rescue loader und flashe dann neu.

    haste "wichtige" Sachen im alten Image kann man das backup auch entpacken ( z.B. mittels 7zip ) um an diese Daten zu kommen.

  • Das mit dem Flashen und neues Image drauf, ist für mich die absolut letzte Alternative.
    ich nutze die DM820 als Partnerbox zu meiner DM920 und habe noch einen Server eingebunden.

    Dann habe ich noch einige zusätzliche Tools installiert und angepasst.


    Das Flashen wäre für mich einiges an Arbeit.


    @QT wo müssen denn die Pakete liegen damit ich das machen kann was du geschrieben hast.
    wäre nett, wenn du mir das genauer erklären könntest.


    Danke euch!