Willkommen! Melden Sie sich an oder registrieren Sie sich.

Um schreiben oder kommentieren zu können, benötigen Sie ein Benutzerkonto.

Anmelden - oder - Benutzerkonto erstellen

"Zwei-Fenster-Dateimanager" für Merlin

  • Da aktuell Spannungen zwischen den einst befreunden Boards bestehen, habe ich persönlich das Problem, daß ich zwischen den Stühlen sitze und immer wieder in nicht supportet GS o. ä. laufe. Ok, mein Problem, habe ich verstanden. Ich möchte das auch nicht werten oder kommentieren. Ich akzeptiere das es so ist.


    Ich nutzte seit Jahren das Merlin Image und habe es immer wieder mit (IMHO sinnvollen) Plugins aus dem anderen Board ergänzt. Eines davon ist der "eCommander" da mir dieser zwei Fenster anbietet und ich diese wirklich oft benötige.

    Da ich ja nun mehr oder weniger angehalten bin diese GP4 Plugins von meinen Boxen zu werfen wenn ich weiterhin das Merlin Image benutzen möchte, würde mich interessieren ob es einen Dateimanager mit zwei Fenstern für das Merlin Image gibt der auch supportet ist?


    Wenn ja, welcher? Leider habe ich bisher nichts finden können.


    Danke im Voraus

  • wieso - nur bei OE2.6 verhindern wir das Installieren/betreiben von GP4.

    Für das OE 2.5 ist das nicht vorgesehen, einzigst bekommt man dann hier keinen Team-Support für diese Konstellation.

  • Ich möchte nicht jammern was auch auf der dm920 momentan nicht geht oder klemmt. Alles gut, ich möchte keinen Support, ist alles ok.

    Ich habe lediglich die Frage: Gibt einen Dateimanager mit zwei Fenstern für das Merlin Image? Wenn ja, welchen? Wenn es keinen gibt, dann ist das auch eine valide Antwort.


    Vielen Dank im Voraus!

  • Ist halt ein simpler File Manager, welcher wirklich nur löschen/verschieben/kopieren/umbenennen kann. :D Im IHAD wurde die Funktionalität mächtig aufgebohrt.


    Nach der Unix-Philosphie "one unique tool for each task" handelnd, ist das Ding aber zum Files schubsen durchaus brauchbar. :teufel: Zwei Fenster hat es schon mal.

  • Ist halt ein simpler File Manager, welcher wirklich nur löschen/verschieben/kopieren/umbenennen kann. :D ....

    Ja, leider ist der enigma2-plugin-extensions-filebrowser sehr rudimentär. Damit komme ich leider nicht weiter.

    Ich müßt schon ein Skript aus dem File Manger starten können.

  • "Execute On PowerEvent" ist ein Plugin, welches beim Ein- und Ausschalten der Box (automatisch) je ein Skript starten kann. Könnte ja sein, das du gar nicht manuell rumstarten willst. :D


    Mir fällt gerade sehr wenig ein, was ich manuell starten wollen würde. Aber da hat ja jeder seine eigenen Vorstellungen.


    Wie auch immer. Es kommt ja eh bald ein Merlin Update.

  • Fehlt Dir nur noch das ausführen eines Scripts?

    Das könnte ja jemand in das auf GIT liegende Plugin einbauen.


    Wenn aber noch mehr dazu kommt, dann wäre es ja mehr ein Nachbau eines bestehenden Plugins - wofür sich keiner finden wird.

    Boxen: DM7080HD, DM820HD, DM8000, DM900ultraHD, DM920ultraHD, Dreambox One UltraHD

    In 50% sitzt das Problem vor dem Gerät und bei den anderen 50% hab ich mich geirrt, dass es nicht davor sitzt :cocksy:

  • Gut dann warte ich mal ab.


    Aber auf kurz oder lang muß ich mir als User halt überlegen ob ich Grabenkriege mitmachen möchte und was für PlugIns für mich persönlich wichtig sind.

    Um mal bei den Floskeln zu bleiben: "one face to the customer" ist schon nicht unwichtig und wenn ich ein Image habe das mir das bietet, dann werde ich das wohl nutzen müssen. Bisher war ich echt mehr als zufrieden mit dem Merlin Image, habe es die letzten 10 Jahre, wo immer es möglich war, installiert und auch jedem empfohlen der mich fragte. Ich würde sehr, sehr gerne beim Merlin Image bleiben und die zwei GP4.1 PlugIns runterwerfen wenn ich Alternativen dafür finden würde. Aktuell ist es halt kein schöner Zustand für uns User.

    Und wie gesagt: ich möchte nicht jammern und mich auch nicht beschweren und schon gar nicht die Situation kritisieren, das geht mich alles nichts an und vor allem interessiert es mich auch nicht was da los ist.


    Ich hole mir einen Kaffee und warte halt mal weiter ab ... :k-a-ff-ee:

  • ähm, das ist aber keine Antwort auf meine Frage :(


    Ich kann mit Deinem Text nix anfangen. Was erwartest Du denn vom Merlin Team?

    Und wenn DU von anderen als Merlin etwas erwartest, dann bist Du hier falsch ;)

    Boxen: DM7080HD, DM820HD, DM8000, DM900ultraHD, DM920ultraHD, Dreambox One UltraHD

    In 50% sitzt das Problem vor dem Gerät und bei den anderen 50% hab ich mich geirrt, dass es nicht davor sitzt :cocksy:

  • "All you can eat" gibt es zur Happy Hour um's Eck beim Chinesen. Ich bin raus. :2eek:


    Dankenswerterweise sind seitens des IHAD Teams Depends eingebaut, die einen Einsatz auf älteren Imageständen verhindern. Ich mag mir gar nicht vorstellen was los wäre, wenn dem nicht so wäre.

  • @AttilaE schreib doch kurz und knackig was du möchtest, dann schaun wir mal.

    1. mit dem Filebrowser ein Script ausführen. Das ist machbar.

    2. .....

    3. .....

  • Oh ich glaube, da habe ich mich offenbar falsch ausgedrückt.

    Ich möchte gar nichts! Niemand soll etwas programmieren oder einbauen o. ä.

    Ganau das was jetzt passiert ist wollte ich ja vermeiden ...


    Dann kopiere ich einfach nochmal meine Ursprüngliche Anfrage von oben hierher:

    Gibt es einen Dateimanager mit zwei Fenstern für das Merlin Image? Wenn ja, welchen? Wenn es keinen gibt, dann ist das auch eine valide Antwort.
    In diesem Dateimanager möchte ich per Tastendruck Skripte ausführen können. That's all!

  • Gibt es einen Dateimanager mit zwei Fenstern für das Merlin Image? Wenn ja, welchen? Wenn es keinen gibt, dann ist das auch eine valide Antwort.
    In diesem Dateimanager möchte ich per Tastendruck Skripte ausführen können. That's all!

    Nein.


    Es gibt Filebrowser -> 2 Fenster

    Es gibt DreamExplorer -> Kann Skripte ausführen

  • Und es gibt jetzt eine Testversion mit 2 Dateifenster und mit der Taste '8' kann man ein Script ausführen.

    Nicht mehr und nicht weniger, waren 4 Zeilen.


    @AttilaE, kopiere die plugin.py nach /usr/lib/enigma2/python/Plugins/Extensions/Filebrowser/

    Die alte plugin.py überschreiben. GUI-Restart nicht vergessen.